VATSIM Germany Forum

Zurück   VATSIM Germany Forum > VATSIM Software > swift - Open Source Pilot Client

swift - Open Source Pilot Client Open Source Pilot Client - Crossplattform, Pluginfähig, von Usern für User

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 2019-04-13, 12:05   #1 (permalink)
 
Registriert seit: 2014-12-22
Ort: Berlin (EDDT)
Alter: 34
Beiträge: 907
Danke erteilt: 689
964 Danksagungen in 433 Beiträgen erhalten
Standard Model Matching mit Prepar3D

Entweder bin ich zu blöd beim Model Matching für P3D v4 durchzublicken oder irgendwas klemmt auf meinem Rechner. In X-Plane 11 funktioniert alles bestens aber für Prepar3D kann der Config-Wizard scheinbar die KI-Modelle nicht immer erkennen.

Laut Anzeige unter "Models" werden 2424 Modelle/Objekte gefunden. Beim Erstellen des Sets wird die folgende Anzahl (offensichtliche Szenerie-Objekte aus ZZZZ entfernt) zugewiesen:

"with DB data only", ohne Auswahl einer Distribution: 190
ohne DB data, ohne Auswahl einer Distribution: 2404
ohne DB data, Distributionen AARDVARK, FAIB, FLAI, MISC, MYTRAFFIC, ZZZZ: 7 (3 Kampfjets samt Waffen-Variante + eine Citation)
ohne DB data, alle Distributionen: 190
ohne DB data, alle Distributionen außer PMDG: 168

Wo ist der Unterschied, ob ich alle Distributionen in der Liste auswähle und dann suchen lasse oder ob ich keine ausgewähle und die Frage nach "use all models" mit Yes beantworte?

Ohne Ausschluss von Nicht-KI-Paketen sieht Amsterdam bei mir aus wie bis 2017 Tegel - überall ist Air Berlin, weil offenbar meine PMDG-737 mit wenig Liveries gegenüber den KI-Modellen bevorzugt wird. D.h. statt nur KI-Distributionen auszuwählen müsste ich sämtliche vollwertigen Addons (mit wenig Liveries) manuell aus dem Model Set entfernen.

... ich vermute mal das ist so nicht gewollt und ich bediene irgendwie nur den Wizard falsch?


Installierte KI-Pakete sind MyTraffic 6 und FLAI (enthält FAIB und kA was noch, deshalb hatte ich auf Verdacht oben etwas mehr ausgewählt).

P.S.: "ohne DB data", keine Auswahl, dann alles außer FLAI rauswerfen ergibt 1614 Modelle (nach Login sind aber alle Flugzeuge Citations).
__________________
BER715 | DLH715

Geändert von Daniel Neugebauer (2019-04-13 um 12:11 Uhr)
Daniel Neugebauer ist offline   Mit Zitat antworten
Alt 2019-04-13, 12:51   #2 (permalink)
 
Benutzerbild von Lothar Gentzsch
 
Registriert seit: 2006-10-02
Beiträge: 347
Danke erteilt: 807
455 Danksagungen in 174 Beiträgen erhalten
Standard

Ich empfehle "with DB" zu lassen. Ich benutze das FLAI-Paket und habe seit einem halben Jahr Spaß damit und gute Modelle:

Gehe im Mapping Tool auf "own modells" Dann mit rechtem Mausklick auf das geöffnete Fenster oben "Simulator". Dann "Force model reload" . Dann "P3D models from directory". Dann zum Flai Ordner - simobjects - Aircraft. - Ordner auswählen.
Dann lädt er Dir 1916 modelle in "own models "ein. Du kannst das ganze Paket markieren /Selection) oder nur die Modelle die du sehen möchtest. Im Feld nun wieder rechter Mausklick- "Modelset - ad to own model set".

Wichtig ist: Wenn man nun sein "Model set" zusammengestellt hat, unten rechts auf "save P3D" drücken.
Das war es. Wer noch Fragen hat kann mir auch eine PM schicken. Über Teamspeak - any desk oder Teamviever würde ich helfen.

Geändert von Lothar Gentzsch (2019-04-13 um 12:54 Uhr)
Lothar Gentzsch ist offline   Mit Zitat antworten
Alt 2019-04-13, 13:29   #3 (permalink)
 
Benutzerbild von Andreas Fuchs
 
Registriert seit: 2002-05-29
Alter: 43
Beiträge: 17.421
Danke erteilt: 11.084
22.907 Danksagungen in 6.236 Beiträgen erhalten
Standard

Direkte Hilfe, wie von Lothar, gibt es auch in unserem Discord. https://discordapp.com/invite/R7Atd9A
__________________
Without deviation from the norm, progress is not possible. Frank Zappa
Gruss, Andreas | VATSIM Supervisor
Regelmässig aktuelle Fotos bei Instagram

Andreas Fuchs ist offline   Mit Zitat antworten
Alt 2019-04-13, 18:59   #4 (permalink)
 
Registriert seit: 2014-12-22
Ort: Berlin (EDDT)
Alter: 34
Beiträge: 907
Danke erteilt: 689
964 Danksagungen in 433 Beiträgen erhalten
Standard

Hat leider nicht geklappt, auch mit dem manuell aufgebauten Model Set gibt es nur Citations zu sehen. Wenn ich dann das Citation-Modell deaktiviere, gibt es nach "re-match" ausschließlich Constellations zu sehen.

Wenn ich ins Matching Log gucke dann sehe ich dort, dass zwar Airline und Typ korrekt identifiziert wurden, danach aber wohl keine in der DB verzeichneten Matches werden können? Daraufhin wird (warum auch immer) auf die Constellation zurückgegriffen. Beispiel:

Code:
18
DLH431: Input model: 'DLH431' ' type: 'reverse lookup' ICAO: 'B737 (9641) L2J M CG: 6.8ft' {Livery cc: 'DLH._STD' airline: 'DLH (3221) Lufthansa Op: yes VA: no Mil: no' desc.: 'Standard Lufthansa' F: 'FFFFFF' T: '010066' Mil: no} file: '''
19
DLH431: Matching uses model set of 1613 models
Entries: 1613 | valid DB keys: 0 (0%)
color liveries: 0 | airline liveries: 1569
VTOL: 0 | military: 41 | civilian: 1572
Different airlines: 373
Combined types: 'L2P, L2J, L4T, L4J, L1P, L1J, L1T, L2T, L3J'
Simulators: FSX: 0 P3D: 1613 FS9: 0 XPlane: 0 FG: 0
Data for input model, has combined: yes airline 'DLH': yes
20
DLH431: Setup algorithm: 'reduce + score based' mode: 'by model string, by ICAO, by ICAO aircraft first, by family, by combined code, force civilian, force military, VTOL, scoring, ignore zero scores, scoring, prefer color liveries, rem.from model set, Verify models at startup, Replace models failed to be added' strategy: 'order'
21
DLH431: Excluded 1613 models without DB key
22
DLH431: Using 'reduce + score based' with model set with 0 models
23
DLH431: Empty list, skipping step
Resultiert in: (gekürzt)

Code:
25
DLH431: Logically added remote aircraft: DLH431 [...] rendered: yes 'LOCKHEED L049_2' type: 'matching' ICAO: 'CONI L4P CG: null' {Livery cc: '' airline: ' Op: yes VA: no Mil: no' desc.: '' F: '' T: '' Mil: no} file: ''

Edit 1: Grad noch gesehen, im Log erscheint auch als Warnung:

Zitat:
1613 models without DB data, is this intended?
... öhm, nein? Wie kann das passieren? Ich glaube ja nicht, dass die Modelle nie in die Datenbank eingetragen wurden...?

Was evtl. noch sein könnte: Ich habe glaube ich noch eine alte Version installiert (vor der Umbenennung von BVAI auf FLAI) weil ich mir den Simulator durch den Namenswechsel nicht zerschießen wollte (die Installation der KI-Modelle schien mir ein größerer Eingriff gewesen zu sein). Kann es sein, dass deshalb nichts erkannt wird? Ich finde das trotzdem seltsam - auf welcher Grundlage erfolgt denn die Erkennung? Ich würde davon ausgehen, dass der Namenswechsel des Modellpakets doch an den Modellen nichts geändert haben dürfte? Außerdem war doch das Mapping schon im Gange als das Paket noch BVAI hieß, also müsste es auch Einträge dazu in der DB geben?

Edit 2: Im Mapping Tool stehen die Modelle auch korrekt mit Typ- und Airline-Code drin, nur dass diese nicht in der DB registriert sind scheint fürs Matching ein Problem darzustellen. Eine Boeing der Lufthansa war natürlich ein doofes Beispiel aber auch für einen A320 DLH läufts nicht besser. Nachdem ich nochmal die Schritte von Lothar probiert habe komme ich jetzt im Tab "Model matcher" des Mapping Tools immer auf "'DEFAULT MODEL' type: 'matching' ICAO: 'B737 L2J M CG: null' {Livery cc: 'VFOO._STD' airline: 'FOO FooBar airlines Op: yes VA: yes Mil: no' desc.: 'Standard Foo airlines' F: 'FF0000' T: '0000FF' Mil: no} file: ''".

Edit 3: Tatsache gibt es einen Eintrag für BVAI im Mapping Tool unter Distributors, das aber keinem Simulator zugewiesen ist. Ich kann auch leider keinen Simulator zuweisen. Ich denke das wird das Problem sein, swift scheint die Modelle dadurch komplett zu ignorieren, egal was ich tue?

Der Simulator lässt sich leider nicht mal eben sichern und BVAI zu deinstallieren ist mir zu heikel. Ich werd swift daher wohl erstmal nur für X-Plane aber nicht für Prepar3D nutzen können.
__________________
BER715 | DLH715

Geändert von Daniel Neugebauer (2019-04-13 um 19:42 Uhr)
Daniel Neugebauer ist offline   Mit Zitat antworten
Alt 2019-04-13, 20:02   #5 (permalink)
 
Benutzerbild von Lothar Gentzsch
 
Registriert seit: 2006-10-02
Beiträge: 347
Danke erteilt: 807
455 Danksagungen in 174 Beiträgen erhalten
Standard

Daniel, du kannst SWIFT für P3D benutzen.

Bitte lade dir einfach das FLAI- Paket herunter:

http://flai.bvartcc.com/

Dann installierst du das Paket wo du willst, auf irgendeiner Platte. Dann legst du den Pfad in "own model set" so wie ich es oben beschrieben habe. Übernehme das Paket (oder Teile) ins "Modelset.

Es ist so, daß das neue Paket von FLAI mit unseren gemappten FLAI -Modellen ( aircraft cfg`s) übereinstimmen müssen. Deshalb bitte das neuie Paket irgendwo abladen.
Wenn du das Paket hast - könnte ich dir direkt helfen ( z.B. PM dann kontakten)
Lothar Gentzsch ist offline   Mit Zitat antworten
Alt 2019-04-13, 20:36   #6 (permalink)
 
Registriert seit: 2014-12-22
Ort: Berlin (EDDT)
Alter: 34
Beiträge: 907
Danke erteilt: 689
964 Danksagungen in 433 Beiträgen erhalten
Standard

Mich irritiert, dass die Modelle effektiv geblacklisted wurden - gab es während Eurer Tests Probleme damit oder sind das Nebeneffekte des Versuchs, die Datenbank zu entschlacken, die einfach nicht bedacht wurden? Ich werde sicherlich nicht der einzige mit diesem Problem sein; ließe sich BVAI in swift nicht einfach (gerne nur lokal) wieder reaktivieren?

Ich scheine im Mapping Tool eintragen zu können was ich will, nichts scheint einen Effekt zu haben. Vielleicht bediene ich das Tool auch einfach falsch aber ich vermute eher, dass swift die lokalen Einträge immer durch die bereits in der Online-DB vorhandenen und deaktivierten Einträge ersetzt und damit sofort wieder rauswirft.
__________________
BER715 | DLH715

Geändert von Daniel Neugebauer (2019-04-13 um 20:39 Uhr)
Daniel Neugebauer ist offline   Mit Zitat antworten
Alt 2019-04-13, 21:06   #7 (permalink)
 
Benutzerbild von Klaus Basan
 
Registriert seit: 2011-01-14
Ort: Heidelberg
Beiträge: 1.465
Danke erteilt: 1.866
1.133 Danksagungen in 521 Beiträgen erhalten
Standard Lokale mapping Daten

Es gibt keine lokalen swift mapping Daten. braucht man auch nicht. Die Daten in der DB sind reine Beschreibungen des Modells, Sie geben an dass das Model XYZ eine B737 mit dem ABC Livery ist.

Wenn Du ein mapping erstellst geht das zur DB, wird dort freigeschaltet und ist dann verfügbar. Warum willst Du denn lokale mappings haben?

* In der DB stehen alle bekannten Mappings
* Im model set hast Du die Modelle die du wirklich benutzen willst.

Wenn Du genauer beschreibst was Du machen willst, kann ich da bestimmt helfen oder erklären wie das gedacht ist.

Zitat:
Zitat von Daniel Neugebauer Beitrag anzeigen
Mich irritiert, dass die Modelle effektiv geblacklisted wurden - gab es während Eurer Tests Probleme damit oder sind das Nebeneffekte des Versuchs, die Datenbank zu entschlacken, die einfach nicht bedacht wurden? Ich werde sicherlich nicht der einzige mit diesem Problem sein; ließe sich BVAI in swift nicht einfach (gerne nur lokal) wieder reaktivieren?

Ich scheine im Mapping Tool eintragen zu können was ich will, nichts scheint einen Effekt zu haben. Vielleicht bediene ich das Tool auch einfach falsch aber ich vermute eher, dass swift die lokalen Einträge immer durch die bereits in der Online-DB vorhandenen und deaktivierten Einträge ersetzt und damit sofort wieder rauswirft.
__________________
Klaus Basan D[A|C|E]MBZ | VatGM - Flights on Google Map | swift Pilot client

Geändert von Klaus Basan (2019-04-13 um 21:13 Uhr)
Klaus Basan ist offline   Mit Zitat antworten
Alt 2019-04-13, 21:15   #8 (permalink)
 
Registriert seit: 2014-12-22
Ort: Berlin (EDDT)
Alter: 34
Beiträge: 907
Danke erteilt: 689
964 Danksagungen in 433 Beiträgen erhalten
Standard

Im Normalfall braucht man das ja auch nicht, aber vermutlich sorgt das hier dafür, dass die Modelle von swift als "ist nicht P3D, also nehm ichs nicht für P3D" klassifiziert zu werden, ohne dass ich Einfluss darauf nehmen könnte?

Nur um die Beta testen zu können würde ich mir ungern potentiell den Simulator zerschießen indem ich anfange an den AI-Paketen zu fummeln; die nächste Neuinstallation (aus anderen Gründen) kommt bestimmt irgendwann und dann kommt auch FLAI drauf. Aktuell hab ich aber nur BVAI und hätte eigentlich erwartet, dass ich das auch weiterhin nutzen kann - dürfte swift ja eigentlich egal sein wie das Paket heißt, die Modelle sind dieselben.

Ist auch nicht weiter schlimm; unter X-Plane 11 mit Blubell funktioniert swift bestens - da war es eine wahre Freude heute vormittag in EHAM eine Runde zuzusehen. Einen Testflug hab ich heute zeitlich leider noch nicht geschafft, bisher macht swift aber schonmal eine sehr gute Figur - danke auf jeden Fall schonmal für die viele Arbeit, die Ihr in den Client gesteckt habt, es scheint sich wirklich gelohnt zu haben!

Wenn ich als Einzelfall schlicht BVAI nicht einsetzen kann, bleib ich für P3D halt erstmal noch bei vPilot und nutze swift nur für XP; mit vPilot funktionierte ja auch alles, ein moderner und umfangreicher Client für XP war wesentlich dringender.
__________________
BER715 | DLH715

Geändert von Daniel Neugebauer (2019-04-13 um 21:20 Uhr)
Daniel Neugebauer ist offline   Mit Zitat antworten
Alt 2019-04-13, 21:22   #9 (permalink)
 
Benutzerbild von Klaus Basan
 
Registriert seit: 2011-01-14
Ort: Heidelberg
Beiträge: 1.465
Danke erteilt: 1.866
1.133 Danksagungen in 521 Beiträgen erhalten
Standard

Du brauchst auch nicht an den AI Paketen rumfummeln. swift muss nur wissen wo die Pakete sind. Dann lädst Du im Mapping tool und wählst die aus, die du für das matching nutzen willst.

Nachtrag: verstehe: es geht um das BVAI Thema, müsste eigentlich auch gehen, habe ich aber nicht getestet. Wenn Du willst können wir das ausprobieren, ansonsten auch alles gut.

Die mappings (DB Daten) von FLAI und BVAI sind 1:1 identisch und die BVAI Modelle müssten sofort erkannt werden allerdings als FLAI. Ich habe nur keine mehr bei mir drauf um zu testen ob das geht. Wenn Du willst komme in den Discord Support Channel, support-de und dann zeige ich dir wie das geht.
__________________
Klaus Basan D[A|C|E]MBZ | VatGM - Flights on Google Map | swift Pilot client

Geändert von Klaus Basan (2019-04-13 um 21:46 Uhr)
Klaus Basan ist offline   Mit Zitat antworten
Antwort

  VATSIM Germany Forum > VATSIM Software > swift - Open Source Pilot Client


Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an



Alle Zeitangaben in WEZ +2. Es ist jetzt 15:38 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2006 - 2018 vatsim-germany.org