VATSIM Germany Forum

Zurück   VATSIM Germany Forum > VATSIM Software > vPilot

vPilot Ein simpler Client für FSX und Prepar3D

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 2017-05-12, 13:02   #1 (permalink)
 
Benutzerbild von Maxim Redlinger
 
Registriert seit: 2015-11-23
Ort: Berlin - In der Nähe von Whiskey 2
Beiträge: 86
Danke erteilt: 618
125 Danksagungen in 72 Beiträgen erhalten
Standard Probleme beim Modelmatching

Moin zusammen,

Nachdem ich diverse Threads zu diesem Thema durchgeschaut habe, bin ich langsam mit meinem Latein am Ende. Ich benutze Vpilot und bekomme seit dem Update auf v2 nurnoch solche Fehlermeldungen:
"Failed to create aircraft KLM1824 using model "WoA_FAIB_FSX_B737-800_W_KLM-KLM Royal Dutch Airlines OC". The model may be corrupt or missing. vPilot will try to create the aircraft with a different model."

Ich habe immer die MTL eines bestimmten Netzwerkes verwendet, habe jetzt aber auch noch WOAI installiert, in der Hoffnung das irgendwelche Flugzeuge erkannt werden. Ohne Erfolg. Es steht auch alles in der Prepar3D.cfg drin:

[MAIN]
ContentErrorLogging=0
FIBER_FRAME_TIME_FRACTION=0.01
HideMenuFullscreen=1
HideMenuNormal=0
LabelsSupported=Airplane, Helicopter
Location=-629,-15,1291,1065,\\.\DISPLAY1
LocationFullScreen=0,0,1920,1080,\\.\DISPLAY1
Maximized=1
ShowInfoText=0
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Avatars
SimObjectPaths.2=SimObjects\Weapons
SimObjectPaths.3=SimObjects\Countermeasures
SimObjectPaths.4=SimObjects\IVAO_MTL
SimObjectPaths.5=Aerosoft\Mega Airport Zurich V2.0\simobjects
SimObjectPaths.6=SimObjects\Rotorcraft
SimObjectPaths.7=SimObjects\GroundVehicles
SimObjectPaths.8=SimObjects\Boats
SimObjectPaths.9=SimObjects\Animals
SimObjectPaths.10=SimObjects\Misc
SimObjectPaths.11=SimObjects\Submersible
SimObjectPaths.12=SimObjects\WOAI
SimObjectPathsRemarks=These entries were automatically added from SimObjects.cfg by Migration Tool. Set RepairConfig=0 in MigrationTool.cfg to disable.
User Objects=Airplane, Helicopter, Submersible, ExternalSim, Avatar


Hat jemand noch einen Tipp? Der VMR generator findet alle Flugzeuge und erstellt die Model Matching Rules, trotzdem kann Vpilot keine Flugzeuge "finden". Auch FSINN findet die Flugzeuge, doch spuckt Fehler aus. Prepar3D habe ich neulich erst neu installiert desswegen.

Danke!
__________________
Maxim Redlinger | Mentor RG Berlin
BER2975/DLH59X
Maxim Redlinger ist offline   Mit Zitat antworten
Alt 2017-05-12, 13:40   #2 (permalink)
 
Registriert seit: 2014-04-28
Ort: In der Nähe von EDDL
Beiträge: 296
Danke erteilt: 379
232 Danksagungen in 158 Beiträgen erhalten
Standard

Ich hatte das Problem ebenfalls und habe dann das Default Model einfach auf "Boing 737-800" gesetzt. Dann wird zwar im Zweifel jeder Flieger als 738 dargestellt, aber man sieht wenigstens welche und und die Fehlermeldung kommt nicht mehr.
__________________
C1 RG Bremen
Jonas Richter ist offline   Mit Zitat antworten
Danksagungen
Alt 2017-05-12, 15:10   #3 (permalink)
 
Registriert seit: 2015-09-14
Beiträge: 60
Danke erteilt: 117
71 Danksagungen in 37 Beiträgen erhalten
Standard

Hallo Maxim,

prüfe mal die aircraft.cfg der in der Fehlermeldung genannten Maschine auf folgendes.

1.) die Sektionen [fltsim.0] bis [fltsim.x] müssen aufeinanderfolgend und ohne Lücke (0, 1, 2, 3..., nicht 0, 1, 3, 4...) nummeriert sein
2.) zu jedem Eintrag "texture=" muss das entsprechende Unterverzeichnis existieren und mit Texturen gefüllt sein
__________________
Markus
If you're a simulator pilot and just fly around with glass cockpits you're missing out on what flying is all about. - Hal Stoen
Markus Schober ist offline   Mit Zitat antworten
Danksagungen
Alt 2017-05-12, 15:43   #4 (permalink)
 
Benutzerbild von Maxim Redlinger
 
Registriert seit: 2015-11-23
Ort: Berlin - In der Nähe von Whiskey 2
Beiträge: 86
Danke erteilt: 618
125 Danksagungen in 72 Beiträgen erhalten
Standard

Hi Markus,

Vielen Dank! Ist alles richtig in der .cfg. Der oben genannte Fehler war leider nur ein Beispiel, der kommt leider bei jedem Aircraft-type.

Hat jemand zufälligerweise eine vPilot v1.x bei sich auf dem Rechner liegen? Vielleicht bringe ich es damit wieder zum laufen.
__________________
Maxim Redlinger | Mentor RG Berlin
BER2975/DLH59X
Maxim Redlinger ist offline   Mit Zitat antworten
Alt 2017-05-12, 16:26   #5 (permalink)
 
Registriert seit: 2015-09-14
Beiträge: 60
Danke erteilt: 117
71 Danksagungen in 37 Beiträgen erhalten
Standard

Habe nur noch vPilot-Setup-1.1.5851.23849 vom Januar 2016. Bei Interesse - PM
__________________
Markus
If you're a simulator pilot and just fly around with glass cockpits you're missing out on what flying is all about. - Hal Stoen
Markus Schober ist offline   Mit Zitat antworten
Alt 2017-05-12, 18:27   #6 (permalink)
 
Benutzerbild von Rainer Jurczyk
 
Registriert seit: 2008-06-05
Ort: FULNO
Alter: 57
Beiträge: 1.619
Danke erteilt: 2.268
2.132 Danksagungen in 933 Beiträgen erhalten
Standard

Die Simobjects Paths gehören in P3D doch in die Simobjects.cfg!
__________________
Gruß Rainer
ATCo S2 RG München - exPTD4 - P5 - PTD 2-6

See You in the skies...
Rainer Jurczyk ist offline   Mit Zitat antworten
Alt 2017-05-12, 18:57   #7 (permalink)
 
Registriert seit: 2014-12-22
Ort: Berlin (EDDT)
Alter: 34
Beiträge: 775
Danke erteilt: 565
781 Danksagungen in 356 Beiträgen erhalten
Standard

Die Nutzung der genannten Bibliothek ist ja von ihren "Urhebern" ihrem Herausgeber für andere Zwecke als der Verwendung für das Ursprungsnetzwerk ausdrücklich untersagt worden, soweit ich es mitbekommen habe (zu dem Thema gab es lange nichts neues mehr). Vielleicht verweigert das neue vPilot das Laden dieser Modelle? Hast Du schonmal probiert, was passiert, wenn Du die Bibliothek deaktivierst und die Matching-Regeln neu generieren lässt?
__________________
BER715 | DLH715
Daniel Neugebauer ist offline   Mit Zitat antworten
Alt 2017-05-14, 12:40   #8 (permalink)
 
Benutzerbild von Maxim Redlinger
 
Registriert seit: 2015-11-23
Ort: Berlin - In der Nähe von Whiskey 2
Beiträge: 86
Danke erteilt: 618
125 Danksagungen in 72 Beiträgen erhalten
Standard

Zitat:
Die Simobjects Paths gehören in P3D doch in die Simobjects.cfg!
Die Simobjects.cfg gibt es in V3 von Prepar3D nicht mehr, oder irre ich mich? So weit ich weiß, wurde die mit der normalen .cfg zusammen gelegt. Oder ich bin zu blöd um sie zu finden

@Daniel daran liegt es leider auch nicht. Habe es grade nur mit den WOAI aircrafts probiert. Das selbe, wenn ich Ulimate Traffic verwende..

Danke für die Hilfe bis jetzt!

EDIT: Es gibt aber einen Ordner SimObjects bei %appdata%, die verschiedene Modelle drin hat. Weiß jemand was es damit auf sich hat?
__________________
Maxim Redlinger | Mentor RG Berlin
BER2975/DLH59X

Geändert von Maxim Redlinger (2017-05-14 um 12:45 Uhr)
Maxim Redlinger ist offline   Mit Zitat antworten
Alt 2017-05-14, 13:39   #9 (permalink)
 
Benutzerbild von Maxim Redlinger
 
Registriert seit: 2015-11-23
Ort: Berlin - In der Nähe von Whiskey 2
Beiträge: 86
Danke erteilt: 618
125 Danksagungen in 72 Beiträgen erhalten
Standard

Ich habe die Lösung gefunden! Da ich denke, dass ich nicht der einzige mit diesem Problem, versuch ich es mal zu erkären.

Ich hab zunächst von vPilot v2 zurück auf v1 gewechselt, da damit bei mir alle Probleme anfingen. Der zweite Störfaktor war wohl das Migration-tool von Flightsimestonia. Dies hat automatische Einträge in den .cfg erstellt, die aber wohl teils Fehlerhaft waren. In der .cfg des Tools lassen sich diese automatischen Einträge deaktivieren. Darauf hin habe ich meine Prepar3D.cfg und meine Simobjects.cfg gelöscht (Ja, die gibt es wohl doch noch in v3, ist aber etwas versteckt. Man findet sie hier: C:\Users\all users\Lockheed Martin). Danach hab ich P3D laufen lassen, damit er die default .cfgs erstellt und damit die Einträge des tools entfernt sind.
Danach muss wie sonst auch. in der Simobjects.cfg die Traffic Addons Manuell eingetragen werden. Mit dem VMR generator dann die Rules erstellen und wieder bei vPilot einfügen. Was bei mir der Clou war, war den Modelmatching-test noch einmal laufen zu lassen. Und voilà: Es funktioniert!
Viel Erfolg damit, falls ihr das selbe Problem habt!
__________________
Maxim Redlinger | Mentor RG Berlin
BER2975/DLH59X
Maxim Redlinger ist offline   Mit Zitat antworten
Danksagungen
Antwort

  VATSIM Germany Forum > VATSIM Software > vPilot


Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an



Alle Zeitangaben in WEZ +2. Es ist jetzt 20:30 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2006 - 2018 vatsim-germany.org