VATSIM Germany Forum

Zurück   VATSIM Germany Forum > VATGER Software > SAG-TV

SAG-TV Alles zum ersten "Fernsehsender" der SAG

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 2012-01-28, 16:55   #11 (permalink)
 
Benutzerbild von Klaus Mueller
 
Registriert seit: 2012-01-26
Alter: 38
Beiträge: 19
Danke erteilt: 1
7 Danksagungen in 4 Beiträgen erhalten
Standard

Unter welchem System arbeitest du? Ich habe Snow Leopard und mit dem Proof-of-Concept habe ich geschafft Screenshots zu erstellen und diese in SAG-TV anzeigen zu lassen. Im Fenster und auch Vollbildmodus.

Komplett neu anfangen würde ich nicht, da es einfach mehr Arbeit bedeutet . Der Code an sich ist auch nicht komplex, so dass man sehr einfach grosse Teile austauschen kann.
Klaus Mueller ist offline   Mit Zitat antworten
Alt 2012-01-28, 17:15   #12 (permalink)
 
Registriert seit: 2008-12-16
Ort: KLO 187°/6.2 NM
Alter: 22
Beiträge: 676
Danke erteilt: 675
624 Danksagungen in 332 Beiträgen erhalten
Standard

Ich bin unter Lion (10.7.2). Meiner Meinung nach macht es nicht allzuviel Sinn wenn das Programm nicht unter der aktuellsten Version des OS läuft
__________________
Pol||D-EPOL
You've just lost the game.
Pol Eyschen ist offline   Mit Zitat antworten
Alt 2012-01-28, 17:31   #13 (permalink)
 
Benutzerbild von Klaus Mueller
 
Registriert seit: 2012-01-26
Alter: 38
Beiträge: 19
Danke erteilt: 1
7 Danksagungen in 4 Beiträgen erhalten
Standard

Zitat:
Zitat von Pol Eyschen Beitrag anzeigen
Meiner Meinung nach macht es nicht allzuviel Sinn wenn das Programm nicht unter der aktuellsten Version des OS läuft
Da gebe ich dir vollkommen Recht. Das ist auch mein Ziel und falls es wirklich Probleme verursachen wird ein Screenshot unter Lion zu machen, dann wird es auch gelöst.
Deswegen eins nach dem anderen .

Bin zur Zeit beim UDP-Netzwerkstack. TCP, funktioniert bereits. (Framework https://github.com/robbiehanson/CocoaAsyncSocket)

Wie weit bist du denn mit der Portierung gekommen?
Klaus Mueller ist offline   Mit Zitat antworten
Alt 2012-01-28, 18:04   #14 (permalink)
 
Registriert seit: 2008-12-16
Ort: KLO 187°/6.2 NM
Alter: 22
Beiträge: 676
Danke erteilt: 675
624 Danksagungen in 332 Beiträgen erhalten
Standard

Auch nur bis zum NW-Stack, ebenfalls mit den AsyncSockets
__________________
Pol||D-EPOL
You've just lost the game.
Pol Eyschen ist offline   Mit Zitat antworten
Alt 2012-01-28, 18:17   #15 (permalink)
 
Benutzerbild von Dieter Lotze
 
Registriert seit: 2005-06-01
Ort: Bergisch Gladbach
Alter: 79
Beiträge: 1.295
Danke erteilt: 642
1.469 Danksagungen in 502 Beiträgen erhalten
Standard

Zitat:
Zitat von Klaus Mueller Beitrag anzeigen
Besteht ein Interesse dran, oder sind die Mac-User inzwischen schon auf Alternativen gewechselt?

Grüße
Klaus
Hallo Klaus,
bestimmt würden sich Mac User freuen – ich jedenfalls – im SAG-TV zu senden.
Von einer Alternative habe ich noch nie was gelesen.
Danke für deine Aktivität in dieser Sache.
Gruß
Dieter
__________________
X-Plane 11; iMac 27
Dieter Lotze ist offline   Mit Zitat antworten
Alt 2012-01-30, 00:46   #16 (permalink)
 
Benutzerbild von Klaus Mueller
 
Registriert seit: 2012-01-26
Alter: 38
Beiträge: 19
Danke erteilt: 1
7 Danksagungen in 4 Beiträgen erhalten
Standard 2.0 Beta1 Release

Hiho,

das Wochenende ist jetzt für die App drauf gegangen. Jetzt brauche ich Beta-Tester vor allem die Lion-Benutzer. Bei mir unter Snow Leopard geht es jetzt (sonst würde ich es nicht releasen).

Kurzanleitung:
1. X-Plane starten und über xsquawkbox connecten (Wichtig! Da sonst die Webseite die Daten nicht anzeigt)
2. ScreenPusherX starten
3. Login/Password (SAG-Germany) eingeben
4. CheckConnection Button klicken.
5. Start Capture klicken

Wenn alles gut gelaufen ist, dann taucht das Live-Bild nach kurzer Zeit auf der SAG-TV Webseite auf.

Was nicht funktioniert ist die Anzeige der aktuellen Daten wie Latitude, Wind Direction ...
Das hängt damit zusammen, dass ich keine API für den UDP-Datenaustausch online gefunden habe.

Für mich ist es jetzt eher wichtig, dass die Grundfunktion Bilder machen/versenden unter den meisten Mac-Usern funktioniert. App und die Sourcen habe ich beigefügt.

Grüße
Klaus
Angehängte Dateien
Dateityp: zip ScreenPusherX-2_0_beta1.zip (132,4 KB, 6x aufgerufen)
Dateityp: zip ScreenPusherX-2_0_beta1-Source.zip (387,4 KB, 7x aufgerufen)
Klaus Mueller ist offline   Mit Zitat antworten
Alt 2012-01-30, 16:39   #17 (permalink)
 
Registriert seit: 2008-12-16
Ort: KLO 187°/6.2 NM
Alter: 22
Beiträge: 676
Danke erteilt: 675
624 Danksagungen in 332 Beiträgen erhalten
Standard

Unter 10.7.2 bekomm ich nur ein weisses Bild. Im übrigen sieht es in den Sources danach aus, als wenn du die Screenshotfunktion überhaupt nicht angerührt hättest

EDIT: Beim genaueren durchschauen der Sources finde ich auch keine Routine, die ein Bild aufnimmt um es auf den Server zu schieben
__________________
Pol||D-EPOL
You've just lost the game.

Geändert von Pol Eyschen (2012-01-30 um 16:51 Uhr)
Pol Eyschen ist offline   Mit Zitat antworten
Alt 2012-01-30, 16:46   #18 (permalink)
 
Benutzerbild von Lukas Völlmert
 
Registriert seit: 2011-06-12
Ort: München
Beiträge: 1.783
Danke erteilt: 2.222
1.614 Danksagungen in 841 Beiträgen erhalten
Standard

Richtig ich habe auch nur ein weißes Bild
__________________
Lukas Völlmert
ATCo C1|vPilot|VATSIM Supervisor|X-Plane 10
RG B(i)erlin, je leerer die Frequenz, desto voller werden wir!
Lukas Völlmert ist offline   Mit Zitat antworten
Alt 2012-01-30, 17:15   #19 (permalink)
 
Benutzerbild von Klaus Mueller
 
Registriert seit: 2012-01-26
Alter: 38
Beiträge: 19
Danke erteilt: 1
7 Danksagungen in 4 Beiträgen erhalten
Standard

Die Screenshot-Funktion wurde auch noch nicht verändert, da es unter 10.6.8 (Meine Entwicklungsumgebung) funktioniert und keine Hinweis bezüglich "Deprecated" gibt.
Nach einer Recherche habe ich nun einen Ansatz wie ich diese umschreiben werde.

Zitat:
Zitat von Pol Eyschen Beitrag anzeigen
EDIT: Beim genaueren durchschauen der Sources finde ich auch keine Routine, die ein Bild aufnimmt um es auf den Server zu schieben
Schaue dir die "sendData" Methode genauer an.
---
...
// get image
theShotImage = [theScreenShot getShotWithRect:shotRect];
...
[socket writeData:myJPEGData withTimeout:-1 tag:WELCOME_MSG];
...
----

Habe bisher 2 Tage Arbeit investiert und es gibt noch viel Potenzial es besser zu machen.
Die erste Stufe war es Grundfunktion für 10.5 - 10.6.8 anzubieten und die ganzen
Memory-Leaks aus dem alten Code auszumerzen. Jetzt habe ich eine Stufe auf der ich aufbauen kann.
Wenn ich heute Abend dazu komme, dann werde ich die Screenshot-Klasse umschreiben.
So wie ich gelesen habe, kann es passieren, dass ich das neue AVFoundation-Framework benutzen muss. Dann wird es eh unterschiedliche Klassen für unterschiedliche Systeme geben.

Insofern ... next cup of tea ...
Klaus Mueller ist offline   Mit Zitat antworten
Alt 2012-01-30, 17:17   #20 (permalink)
 
Registriert seit: 2008-12-16
Ort: KLO 187°/6.2 NM
Alter: 22
Beiträge: 676
Danke erteilt: 675
624 Danksagungen in 332 Beiträgen erhalten
Standard

Na dann, disregard last message
__________________
Pol||D-EPOL
You've just lost the game.
Pol Eyschen ist offline   Mit Zitat antworten
Antwort

  VATSIM Germany Forum > VATGER Software > SAG-TV


Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an



Alle Zeitangaben in WEZ +2. Es ist jetzt 11:22 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2006 - 2012 vatsim-germany.org