VATSIM Germany Forum

Zurück   VATSIM Germany Forum > VATSIM Software > Squawkbox

Hinweise

Squawkbox Die Piloten-Software Squawkbox 2.3 und der Nachfolger Squawkbox 3/4

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 2017-08-31, 12:13   #1 (permalink)
 
Registriert seit: 2017-08-27
Beiträge: 14
Danke erteilt: 8
23 Danksagungen in 2 Beiträgen erhalten
Standard PTT Taste bei der xSquawkbox

Moin,

bei meiner xSquawkbox habe ich Probleme mit einer Joystickbutton zuweisung als PTT. Tastatur geht wunderbar, wenn ich jedoch bei Joystick auf Assign drücke kommt sofort Button 17. Dieser ominöse Button wird scheinbar dauerhaft gedrückt. Selbst beim abkoppeln vom USB scheint dieser Button aktiv zu sein...

Alle Einstellungen schon mehrfach überprüft. Gibts ne andere Möglichkeit, die Zuweisung zu tätigen vielleicht über ne config file?

Danke Max
Max Lopter ist offline   Mit Zitat antworten
Alt 2017-08-31, 16:50   #2 (permalink)
 
Benutzerbild von Benjamin Hüllenkremer
 
Registriert seit: 2014-06-28
Beiträge: 395
Danke erteilt: 657
416 Danksagungen in 215 Beiträgen erhalten
Standard

Moin Max,
verstehe ich das richtig, auch wenn du alle USB-Kabel ziehst, schreibt dir ein böser Button eine 17 in das Joystick-Feld? Das wäre ja mysteriös :-/
Deine Beschreibung klingt ansonsten ziemlich nach einem angeschlossenen Controller, der immer wieder was schickt (gerne bei einer Saitek-Throttle der Fall).

Ansonsten schau mal in die Prefs der XSquawkBox, im XPlane Ordner > Resources/plugins/XSquawkBox/Resources/XSquawkBox Prefs. (So auf einem Mac...) Backup der Datei machen, mit NotePad öffnen, nicht mit Word oder so was! Da findet sich der Eintrag "voice_ptt_btn=xxx". Versuche doch, den mal auf den gewünschten Wert zu setzen. Wenn nicht drin, eintragen.
Lass mich wissen, ob es geklappt hat!
__________________
Bassig
Benjamin
FRIESE41
Benjamin Hüllenkremer ist offline   Mit Zitat antworten
Alt 2017-08-31, 18:30   #3 (permalink)
 
Registriert seit: 2017-08-27
Beiträge: 14
Danke erteilt: 8
23 Danksagungen in 2 Beiträgen erhalten
Standard

Zitat:
Zitat von Benjamin Hüllenkremer Beitrag anzeigen
Moin Max,
verstehe ich das richtig, auch wenn du alle USB-Kabel ziehst, schreibt dir ein böser Button eine 17 in das Joystick-Feld? Das wäre ja mysteriös :-/
Deine Beschreibung klingt ansonsten ziemlich nach einem angeschlossenen Controller, der immer wieder was schickt (gerne bei einer Saitek-Throttle der Fall).

Ansonsten schau mal in die Prefs der XSquawkBox, im XPlane Ordner > Resources/plugins/XSquawkBox/Resources/XSquawkBox Prefs. (So auf einem Mac...) Backup der Datei machen, mit NotePad öffnen, nicht mit Word oder so was! Da findet sich der Eintrag "voice_ptt_btn=xxx". Versuche doch, den mal auf den gewünschten Wert zu setzen. Wenn nicht drin, eintragen.
Lass mich wissen, ob es geklappt hat!
werde ich gleich machen vielen Dank.

Ja, das ist total seltsam. Mein Thrustmaster Hotas Warthog sendet definitiv nichts. Habe ich schon mehrfach überprüft und dennoch sagt er sofort Button 17 wäre gedrückt
Max Lopter ist offline   Mit Zitat antworten
Alt 2017-08-31, 19:36   #4 (permalink)
 
Registriert seit: 2017-05-19
Beiträge: 67
Danke erteilt: 15
59 Danksagungen in 27 Beiträgen erhalten
Standard PTT Taste bei der xSquawkbox

Ah, der Warthog... mit dem hatte ich das gleiche Problem. Meine Lösung war nach dem anklicken von "Assign Button" (bzw. schon währenddessen) den PTT-Knopf am Stick immer wieder zu drücken (bei mir ist es der Pinky Switch). Hat zwei oder drei Versuche gebraucht, aber dann hatte ich es.


Gesendet von iPhone mit Tapatalk Pro
Stephan Leukert ist offline   Mit Zitat antworten
Alt 2017-08-31, 20:29   #5 (permalink)
 
Registriert seit: 2017-08-27
Beiträge: 14
Danke erteilt: 8
23 Danksagungen in 2 Beiträgen erhalten
Standard

Zitat:
Zitat von Stephan Leukert Beitrag anzeigen
Ah, der Warthog... mit dem hatte ich das gleiche Problem. Meine Lösung war nach dem anklicken von "Assign Button" (bzw. schon währenddessen) den PTT-Knopf am Stick immer wieder zu drücken (bei mir ist es der Pinky Switch). Hat zwei oder drei Versuche gebraucht, aber dann hatte ich es.


Gesendet von iPhone mit Tapatalk Pro
Das kannste knicken... egal was ich drücke es kommt immer 17.

Weiß jemand wie ich rausfinden kann, wie die Nummern von den Buttons im XPL zustandekommen? hatte jetzt manuell auf 16 geändert was hinten der Hebel sein sollte, das klappt aber nicht.
Max Lopter ist offline   Mit Zitat antworten
Alt 2017-08-31, 20:31   #6 (permalink)
 
Registriert seit: 2017-08-27
Beiträge: 14
Danke erteilt: 8
23 Danksagungen in 2 Beiträgen erhalten
Standard

Okay kleines Update. Ich habe jetzt einfach mal aus Spaß die 17 drinnen gelassen. Gemäß xSquawkbox müsste ich dann ja auf dauersenden sein. Nur sende ich einfach gar nichts Also warum will er ständig einen Button auswählen der scheinbar gar kein Signal von sich gibt
Max Lopter ist offline   Mit Zitat antworten
Alt 2017-08-31, 20:32   #7 (permalink)
 
Registriert seit: 2017-05-19
Beiträge: 67
Danke erteilt: 15
59 Danksagungen in 27 Beiträgen erhalten
Standard

Bin leider heute Abend nicht zuhause, sonst hätte ich Dir sagen können, welchen Wert der Hebel hat. Morgen früh bin ich aussagekräftiger .


Gesendet von iPhone mit Tapatalk Pro
Stephan Leukert ist offline   Mit Zitat antworten
Danksagungen
Alt 2017-08-31, 23:03   #8 (permalink)
 
Benutzerbild von Benjamin Hüllenkremer
 
Registriert seit: 2014-06-28
Beiträge: 395
Danke erteilt: 657
416 Danksagungen in 215 Beiträgen erhalten
Standard

Ok, habe keinen Warthog... Probier sonst mal das mit den Prefs, wenn du eine Nummer von Stephan hast...
__________________
Bassig
Benjamin
FRIESE41
Benjamin Hüllenkremer ist offline   Mit Zitat antworten
Alt 2017-09-01, 07:48   #9 (permalink)
 
Registriert seit: 2017-05-19
Beiträge: 67
Danke erteilt: 15
59 Danksagungen in 27 Beiträgen erhalten
Standard

Ich habe nachgesehen, bei mir hat der Hebel den Wert 323.
Stephan Leukert ist offline   Mit Zitat antworten
Alt 2017-09-01, 09:44   #10 (permalink)
VATSIM Germany RG München Chief
 
Registriert seit: 2009-09-10
Ort: EDDM
Alter: 42
Beiträge: 1.890
Danke erteilt: 3.887
1.633 Danksagungen in 855 Beiträgen erhalten
Standard

Dieser Wert von 323 kann auf jedem Rechner anders sein.
Ich habe XPlane auf 2 Rechnern und in jedem der beiden Rechner habe ich für meine Joysticks unterschiedlich Werte für die Buttons.
Wenn man wissen möchte, welcher Button welchen Wert hat, dann sollte man das LUA-Plugin nehmen und es sich damit ausgeben lassen.
__________________
Chief RG-München
Christian Speth ist gerade online   Mit Zitat antworten
Antwort

  VATSIM Germany Forum > VATSIM Software > Squawkbox


Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an



Alle Zeitangaben in WEZ +2. Es ist jetzt 10:50 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2006 - 2012 vatsim-germany.org