VATSIM Germany Forum

Zurück   VATSIM Germany Forum > Training > Piloten-Ecke

Piloten-Ecke Wie fliegt man richtig? (Verfahren, Phraseologie und mehr)

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 2017-10-16, 18:22   #1 (permalink)
 
Benutzerbild von Jörg Dolgner
 
Registriert seit: 2004-05-21
Ort: Dinslaken EDLD
Alter: 52
Beiträge: 3.760
Danke erteilt: 4.251
2.932 Danksagungen in 1.237 Beiträgen erhalten
Standard [Problem gelöst] VATSIM Flightplan Prefile mit Firefox und NoScript

Moin!

Ich benutze Firefox mit aktivem NoScript-Add-on als Standardbrowser. Beim CTP am 14.10.2017 hatte ich das Problem, dass PFPX den Flugplan für das VATSIM-Prefiling nicht korrekt an den Browser übertragen konnte. Auf die Schnelle musste ich alles per Hand eingeben … Bei meinem letzten Online-Flug davor am 08.10.2017 hatte es noch funktioniert. Dieses Problem ist aber nicht PFPX-spezifisch, sondern betrifft wahrscheinlich jede Drittanbieteranwendung, die Daten auf die VATSIM-Flightplan-Prefile-Seite schreiben möchte, wenn man wie ich Firefox/NoScript benutzt.

Heute hatte ich etwas Gelegenheit, mich näher mit dem Problem zu beschäftigen, und konnte es lösen. Damit andere auch was von meiner Lösung haben, poste ich sie hier - im allgemeinen VATSIM-Forum steht sie bereits.

Da das Prefiling mit dem IE als temporär aktiviertem Standardbrowser problemlos ging, konnte eigentlich nur ein Update bei Firefox oder dem NoScript-Add-on den Fehler verursacht haben.

Zunächst einmal ist seit dem letzten Firefox-Update das Icon für NoScript aus der Icon-Leiste verschwunden. In einem anderen Forum habe ich dafür den folgenden Tipp gefunden (englisches Original hier):
  1. Firefox-Menü => Hilfe => Mit deaktivierten Add-ons neu starten …
  2. Auf den Button "Im abgesicherten Modus fortfahren" (oder so ähnlich) klicken
  3. Nach diesem Neustart Firefox schließen und noch einmal ganz normal neu starten - das NoScript UI sollte wieder da sein!

So, nun zur Lösung des eigentlichen Problems:
  1. Auf das (bestenfalls soeben wiederhergestellte) NoScript-Icon klicken => Einstellungen …
  2. Reiter "Erweitert" => Reiter in 2. Reihe "Cross-Site Scripting (XSS)" => Eingabefeld "Ausnahmen vom XSS-Schutz"
  3. Das Feld um folgende neue Zeile ergänzen und auf OK klicken - jetzt sollte das Prefiling wieder funktionieren!

Code:
^https?://(www|cert)\.vatsim\.net/fp/(file\.php)?\?1=.*
Das Ganze sollte ungefähr so aussehen wie in meinem Bildanhang.

__________________
Tschö wa, Jörg

MQT66J ~~~ DLH6514 ~~~ D [C|E|F|G|H|I] JDO

Jörg Dolgner ist offline   Mit Zitat antworten
Antwort

  VATSIM Germany Forum > Training > Piloten-Ecke


Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are an
Pingbacks are an
Refbacks are an



Alle Zeitangaben in WEZ +2. Es ist jetzt 19:54 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2006 - 2012 vatsim-germany.org